RubySec

Providing security resources for the Ruby community

CVE-2013-1800 (crack): CVE-2013-1800 rubygem-crack: YAML parameter parsing vulnerability

ADVISORIES

GEM

crack

SEVERITY

CVSS v2: 7.5 (High)

PATCHED VERSIONS

  • >= 0.3.2

DESCRIPTION

The crack gem 0.3.1 and earlier for Ruby does not properly restrict casts of string values, which might allow remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service (memory and CPU consumption) by leveraging Action Pack support for (1) YAML type conversion or (2) Symbol type conversion, a similar vulnerability to CVE-2013-0156.