RubySec

Providing security resources for the Ruby community

CVE-2014-1832 (passenger): CVE-2014-1831 CVE-2014-1832 rubygem-passenger: insecure use of temporary files

ADVISORIES

GEM

passenger

SEVERITY

CVSS v2: 2.1 (Low)

PATCHED VERSIONS

  • >= 4.0.38

DESCRIPTION

Phusion Passenger 4.0.37 allows local users to write to certain files and directories via a symlink attack on (1) control_process.pid or a (2) generation-* file. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-1831.