RubySec

Providing security resources for the Ruby community

CVE-2017-0904 (private_address_check): private_address_check Ruby Gem Resolv.getaddresses Server-Side Request Forgery

ADVISORIES

GEM

private_address_check

SEVERITY

CVSS v3: 8.1

CVSS v2: 6.8

PATCHED VERSIONS

  • >= 0.4.0

DESCRIPTION

The private_address_check ruby gem before 0.4.0 is vulnerable to a bypass due to use of Ruby’s Resolv.getaddresses method, which is OS-dependent and should not be relied upon for security measures, such as when used to blacklist private network addresses to prevent server-side request forgery.