RubySec

Providing security resources for the Ruby community

CVE-2017-11430 (omniauth-saml): omniauth-saml authentication bypass via incorrect XML canonicalization and DOM traversal

ADVISORIES

GEM

omniauth-saml

SEVERITY

CVSS v3: 9.8 (Critical)

CVSS v2: 7.5 (High)

PATCHED VERSIONS

  • >= 1.10.0

DESCRIPTION

OmniAuth OmnitAuth-SAML 1.9.0 and earlier may incorrectly utilize the results of XML DOM traversal and canonicalization APIs in such a way that an attacker may be able to manipulate the SAML data without invalidating the cryptographic signature, allowing the attack to potentially bypass authentication to SAML service providers.