CVSS v3.x: 8.8 (High)
- >= 1.7.2
nokogiri version 1.7.2 has been released.
This is a security update based on 1.7.1, addressing two upstream libxslt 1.1.29 vulnerabilities classified as "Medium" by Canonical and given a CVSS3 score of "6.5 Medium" and "8.8 High" by RedHat.
These patches only apply when using Nokogiri’s vendored libxslt package. If you’re using your distro’s system libraries, there’s no need to upgrade from 188.8.131.52 or 1.7.1 at this time.
Full details are available at the github issue linked to in the changelog below.
1.7.2 / 2017-05-09
[MRI] Upstream libxslt patches are applied to the vendored libxslt 1.1.29 which address CVE-2017-5029 and CVE-2016-4738.
For more information: