RubySec

Providing security resources for the Ruby community

CVE-2017-7540 (safemode): Safemode Gem for Ruby is vulnerable to bypassing safe mode limitations

ADVISORIES

GEM

safemode

PATCHED VERSIONS

  • >= 1.3.3

DESCRIPTION

Safemode, as used in Foreman, versions 1.3.2 and earlier are vulnerable to bypassing safe mode limitations via special Ruby syntax. This can lead to deletion of objects for which the user does not have delete permissions or possibly to privilege escalation.