RubySec

Providing security resources for the Ruby community

CVE-2018-14040 (bootstrap): XSS vulnerabilities via data-parent, data-target, data-container in bootstrap

ADVISORIES

GEM

bootstrap

SEVERITY

CVSS v3: 6.1

CVSS v2: 4.3

PATCHED VERSIONS

  • >= 4.1.2

DESCRIPTION

In Bootstrap before 4.1.2, XSS is possible in collapse data-parent attribute (CVE-2018-14040), data-target property of scrollspy (CVE-2018-14041), data-container property of tooltip (CVE-2018-14042)