RubySec

Providing security resources for the Ruby community

CVE-2019-18409 (ruby_parser-legacy): ruby_parser-legacy world writable files allow local privilege escalation

ADVISORIES

GEM

ruby_parser-legacy

SEVERITY

CVSS v3: 7.8

CVSS v2: 4.6

PATCHED VERSIONS

None.

DESCRIPTION

The ruby_parser-legacy (aka legacy) gem 1.0.0 for Ruby allows local privilege escalation because of world-writable files. For example, if the brakeman gem (which has a legacy dependency) 4.5.0 through 4.7.0 is used, a local user can insert malicious code into the ruby_parser-legacy-1.0.0/lib/ruby_parser/legacy/ruby_parser.rb file.