Rubysec

Providing security resources for the Ruby community.
Follow us @rubysec or email us via info at rubysec.com

Advisory Archive

Back

---
gem: actionpack
date: 2016-01-25
url: https://groups.google.com/forum/#!topic/rubyonrails-security/335P1DcLG00
cve: 2016-0752
title: Possible Information Leak Vulnerability in Action View
description: |
  There is a possible directory traversal and information leak vulnerability in
  Action View. This vulnerability has been assigned the CVE identifier
  CVE-2016-0752.

  Versions Affected:  All.
  Not affected:       None.
  Fixed Versions:     5.0.0.beta1.1, 4.2.5.1, 4.1.14.1, 3.2.22.1

  Impact
  ------
  Applications that pass unverified user input to the `render` method in a
  controller may be vulnerable to an information leak vulnerability.

  Impacted code will look something like this:

  ```ruby
  def index
    render params[:id]
  end
  ```

  Carefully crafted requests can cause the above code to render files from
  unexpected places like outside the application's view directory, and can
  possibly escalate this to a remote code execution attack.

  All users running an affected release should either upgrade or use one of the
  workarounds immediately.

  Releases
  --------
  The FIXED releases are available at the normal locations.

  Workarounds
  -----------
  A workaround to this issue is to not pass arbitrary user input to the `render`
  method.  Instead, verify that data before passing it to the `render` method.

  For example, change this:

  ```ruby
  def index
    render params[:id]
  end
  ```

  To this:

  ```ruby
  def index
    render verify_template(params[:id])
  end

  private
  def verify_template(name)
    # add verification logic particular to your application here
  end
  ```

  Patches
  -------
  To aid users who aren't able to upgrade immediately we have provided patches for
  the two supported release series. They are in git-am format and consist of a
  single changeset.

  * 3-2-render_data_leak.patch - Patch for 3.2 series
  * 4-1-render_data_leak.patch - Patch for 4.1 series
  * 4-2-render_data_leak.patch - Patch for 4.2 series
  * 5-0-render_data_leak.patch - Patch for 5.0 series

  Please note that only the 4.1.x and 4.2.x series are supported at present. Users
  of earlier unsupported releases are advised to upgrade as soon as possible as we
  cannot guarantee the continued availability of security fixes for unsupported
  releases.

  Credits
  -------
  Thanks John Poulin for reporting this!
unaffected_versions:
- ">= 4.1.0"
patched_versions:
- ">= 5.0.0.beta1.1"
- "~> 4.2.5, >= 4.2.5.1"
- "~> 4.1.14, >= 4.1.14.1"
- "~> 3.2.22.1"