Rubysec

Providing security resources for the Ruby community.
Follow us @rubysec or email us via info at rubysec.com

Advisory Archive

Back

---
gem: ffi
date: 2018-06-22
url: https://github.com/ffi/ffi/releases/tag/1.9.24
cve: 2018-1000201
title: ruby-ffi DDL loading issue on Windows OS
description: |
  ruby-ffi version 1.9.23 and earlier has a DLL loading issue which can be
  hijacked on Windows OS, when a Symbol is used as DLL name instead of a String
  This vulnerability appears to have been fixed in v1.9.24 and later.
cvss_v2: '6.8'
cvss_v3: '7.8'
patched_versions:
- ">= 1.9.24"
related:
  url: '["https://github.com/ffi/ffi/commit/09e0c6076466b4383da7fa4e13f714311109945a",
    "https://github.com/ffi/ffi/commit/e0fe486df0e117ed67b0282b6ada04b7214ca05c"]'