Rubysec

Providing security resources for the Ruby community.
Follow us @rubysec or email us via info at rubysec.com

Advisory Archive

Back

---
gem: nokogiri
date: 2016-01-19
url: https://groups.google.com/forum/#!topic/ruby-security-ann/Dy7YiKb_pMM
cve: 2015-7499
title: 'Nokogiri gem contains a heap-based buffer overflow vulnerability in libxml2

'
description: |
  Nokogiri version 1.6.7.2 has been released, pulling in several upstream
  patches to the vendored libxml2 to address the following CVE:

  CVE-2015-7499
  CVSS v2 Base Score: 5.0 (MEDIUM)

  Heap-based buffer overflow in the xmlGROW function in parser.c
  in libxml2 before 2.9.3 allows context-dependent attackers to
  obtain sensitive process memory information via unspecified
  vectors.

  libxml2 could be made to crash if it opened a specially crafted
  file. It was discovered that libxml2 incorrectly handled certain
  malformed documents. If a user or automated system were tricked
  into opening a specially crafted document, an attacker could
  possibly cause libxml2 to crash, resulting in a denial of service.
cvss_v2: '5.0'
unaffected_versions:
- "< 1.6.0"
patched_versions:
- ">= 1.6.7.2"
related:
  url: '["https://github.com/sparklemotion/nokogiri/commit/9eb540e7c905924a42757bf0a34c2c00707d536c"]'