Rubysec

Providing security resources for the Ruby community.
Follow us @rubysec or email us via info at rubysec.com

Advisory Archive

Back

---
gem: rubygems-update
date: 2019-03-05
url: https://blog.rubygems.org/2019/03/05/security-advisories-2019-03.html
cve: 2019-8324
title: Installing a malicious gem may lead to arbitrary code execution
description: |
  An issue was discovered in RubyGems 2.6 and later through 3.0.2. A crafted
  gem with a multi-line name is not handled correctly. Therefore, an attacker
  could inject arbitrary code to the stub line of gemspec, which is eval-ed by
  code in ensure_loadable_spec during the preinstall check.
unaffected_versions:
- "< 2.6"
patched_versions:
- ">= 3.0.3"
- "~> 2.7.9"