Rubysec

Providing security resources for the Ruby community.
Follow us @rubysec or email us via info at rubysec.com

Advisory Archive

Back

---
gem: rubygems-update
date: 2019-03-05
url: https://blog.rubygems.org/2019/03/05/security-advisories-2019-03.html
cve: 2019-8325
title: Escape sequence injection vulnerability in errors
description: |
  An issue was discovered in RubyGems 2.6 and later through 3.0.2. Since
  Gem::CommandManager#run calls alert_error without escaping, escape sequence
  injection is possible. (There are many ways to cause an error.)
unaffected_versions:
- "< 2.6"
patched_versions:
- ">= 3.0.3"
- "~> 2.7.9"