RubySec

Providing security resources for the Ruby community

CVE-2014-2538 (rack-ssl): CVE-2014-2538 rubygem rack-ssl: URL error display XSS

ADVISORIES

GEM

rack-ssl

SEVERITY

CVSS v2: 4.3 (Medium)

PATCHED VERSIONS

  • >= 1.3.4

DESCRIPTION

Cross-site scripting (XSS) vulnerability in lib/rack/ssl.rb in the rack-ssl gem before 1.4.0 for Ruby allows remote attackers to inject arbitrary web script or HTML via a URI, which might not be properly handled by third-party adapters such as JRuby-Rack.