RubySec

Providing security resources for the Ruby community

CVE-2017-0902 (rubygems-update): RubyGems DNS request hijacking vulnerability

ADVISORIES

GEM

rubygems-update

SEVERITY

CVSS v2: 6.8

PATCHED VERSIONS

  • >= 2.4.5.3
  • >= 2.5.2.1
  • >= 2.6.13

DESCRIPTION

RubyGems version 2.6.12 and earlier is vulnerable to a DNS hijacking vulnerability that allows a MITM attacker to force the RubyGems client to down load and install gems from a server that the attacker controls.