RubySec

Providing security resources for the Ruby community

CVE-2017-0901 (rubygems-update): RubyGems vulnerability in the gem installer that allowed a malicious gem to overwrite arbitrary files

ADVISORIES

GEM

rubygems-update

LIBRARY

rubygems

SEVERITY

CVSS v2: 6.4 (Medium)

PATCHED VERSIONS

  • >= 2.4.5.3
  • >= 2.5.2.1
  • >= 2.6.13

DESCRIPTION

RubyGems version 2.6.12 and earlier fails to validate specification names, allowing a maliciously crafted gem to potentially overwrite any file on the filesystem.