RubySec

Providing security resources for the Ruby community

CVE-2017-0900 (rubygems-update): RubyGems DoS vulnerability in the query command

ADVISORIES

GEM

rubygems-update

SEVERITY

CVSS v2: 5.0

PATCHED VERSIONS

  • >= 2.4.5.3
  • >= 2.5.2.1
  • >= 2.6.13

DESCRIPTION

RubyGems version 2.6.12 and earlier is vulnerable to maliciously crafted gem specifications to cause a denial of service attack against RubyGems clients who have issued a query command.