RubySec

Providing security resources for the Ruby community

CVE-2017-0899 (rubygems-update): RubyGems ANSI escape sequence vulnerability

ADVISORIES

GEM

rubygems-update

LIBRARY

RubyGems

SEVERITY

CVSS v2.0: 7.5 (High)

PATCHED VERSIONS

  • >= 2.4.5.3
  • >= 2.5.2.1
  • >= 2.6.13

DESCRIPTION

RubyGems version 2.6.12 and earlier is vulnerable to maliciously crafted gem specifications that include terminal escape characters. Printing the gem specification would execute terminal escape sequences.