RubySec

Providing security resources for the Ruby community

CVE-2019-11027 (ruby-openid): ruby-openid SSRF via claimed_id request

ADVISORIES

GEM

ruby-openid

SEVERITY

CVSS v3: 9.8

PATCHED VERSIONS

  • >= 2.9.0

DESCRIPTION

Ruby OpenID (aka ruby-openid) through 2.8.0 has a remotely exploitable flaw. This library is used by Rails web applications to integrate with OpenID Providers. Severity can range from medium to critical, depending on how a web application developer chose to employ the ruby-openid library. Developers who based their OpenID integration heavily on the “example app” provided by the project are at highest risk.