RubySec

Providing security resources for the Ruby community

CVE-2022-22577 (actionpack): Possible XSS Vulnerability in Action Pack

ADVISORIES

GEM

actionpack

FRAMEWORK

Ruby on Rails

UNAFFECTED VERSIONS

  • < 5.2.0

PATCHED VERSIONS

  • ~> 5.2.7, >= 5.2.7.1
  • ~> 6.0.4, >= 6.0.4.8
  • ~> 6.1.5, >= 6.1.5.1
  • >= 7.0.2.4

DESCRIPTION

There is a possible XSS vulnerability in Rails / Action Pack. This vulnerability has been assigned the CVE identifier CVE-2022-22577.

Versions Affected: >= 5.2.0 Not affected: < 5.2.0 Fixed Versions: 7.0.2.4, 6.1.5.1, 6.0.4.8, 5.2.7.1

Impact

CSP headers were only sent along with responses that Rails considered as "HTML" responses. This left API requests without CSP headers, which could possibly expose users to XSS attacks.

Releases

The FIXED releases are available at the normal locations.

Workarounds

Set a CSP for your API responses manually.

RELATED