RubySec

Providing security resources for the Ruby community

CVE-2022-30123 (rack): Possible shell escape sequence injection vulnerability in Rack

ADVISORIES

GEM

rack

PATCHED VERSIONS

  • ~> 2.0.9, >= 2.0.9.1
  • ~> 2.1.4, >= 2.1.4.1
  • >= 2.2.3.1

DESCRIPTION

There is a possible shell escape sequence injection vulnerability in the Lint and CommonLogger components of Rack. This vulnerability has been assigned the CVE identifier CVE-2022-30123.

Versions Affected: All. Not affected: None Fixed Versions: 2.0.9.1, 2.1.4.1, 2.2.3.1

Impact

Carefully crafted requests can cause shell escape sequences to be written to the terminal via Rack’s Lint middleware and CommonLogger middleware. These escape sequences can be leveraged to possibly execute commands in the victim’s terminal.

Impacted applications will have either of these middleware installed, and vulnerable apps may have something like this:

use Rack::Lint

Or

use Rack::CommonLogger

All users running an affected release should either upgrade or use one of the workarounds immediately.

Workarounds

Remove these middleware from your application