RubySec

Providing security resources for the Ruby community

CVE-2007-0469 (rubygems-update): CVE-2007-0469 RubyGems: Specially-crafted Gem archive can overwrite system files

ADVISORIES

GEM

rubygems-update

LIBRARY

rubygems

SEVERITY

CVSS v2: 9.3

PATCHED VERSIONS

  • >= 0.9.1

DESCRIPTION

The extract_files function in installer.rb in RubyGems before 0.9.1 does not check whether files exist before overwriting them, which allows user-assisted remote attackers to overwrite arbitrary files, cause a denial of service, or execute arbitrary code via crafted GEM packages.