RubySec

Providing security resources for the Ruby community

CVE-2013-4363 (rubygems-update): CVE-2013-4363 rubygems: version regex algorithmic complexity vulnerability, incomplete CVE-2013-4287 fix

ADVISORIES

GEM

rubygems-update

LIBRARY

rubygems

SEVERITY

CVSS v2: 4.3 (Medium)

PATCHED VERSIONS

  • ~> 1.8.23.2
  • ~> 1.8.27
  • ~> 2.0.10
  • >= 2.1.5

DESCRIPTION

Algorithmic complexity vulnerability in Gem::Version::ANCHORED_VERSION_PATTERN in lib/rubygems/version.rb in RubyGems before 1.8.23.2, 1.8.24 through 1.8.26, 2.0.x before 2.0.10, and 2.1.x before 2.1.5, as used in Ruby 1.9.0 through 2.0.0p247, allows remote attackers to cause a denial of service (CPU consumption) via a crafted gem version that triggers a large amount of backtracking in a regular expression. NOTE: this issue is due to an incomplete fix for CVE-2013-4287.