RubySec

Providing security resources for the Ruby community

CVE-2016-11086 (oauth): Improper Certificate Validation in oauth ruby gem

ADVISORIES

GEM

oauth

SEVERITY

CVSS v3: 7.4

PATCHED VERSIONS

  • >= 0.5.5

DESCRIPTION

lib/oauth/consumer.rb in the oauth-ruby gem through 0.5.4 for Ruby does not verify server X.509 certificates if a certificate bundle cannot be found, which allows man-in-the-middle attackers to spoof servers and obtain sensitive information.