RubySec

Providing security resources for the Ruby community

CVE-2019-8324 (rubygems-update): Installing a malicious gem may lead to arbitrary code execution

ADVISORIES

GEM

rubygems-update

LIBRARY

rubygems

SEVERITY

CVSS v3: 8.8 (High)

UNAFFECTED VERSIONS

  • < 2.6

PATCHED VERSIONS

  • >= 3.0.3
  • ~> 2.7.9

DESCRIPTION

An issue was discovered in RubyGems 2.6 and later through 3.0.2. A crafted gem with a multi-line name is not handled correctly. Therefore, an attacker could inject arbitrary code to the stub line of gemspec, which is eval-ed by code in ensure_loadable_spec during the preinstall check.