RubySec

Providing security resources for the Ruby community

CVE-2019-8325 (rubygems-update): Escape sequence injection vulnerability in errors

ADVISORIES

GEM

rubygems-update

LIBRARY

rubygems

SEVERITY

CVSS v3: 7.5 (High)

UNAFFECTED VERSIONS

  • < 2.6

PATCHED VERSIONS

  • >= 3.0.3
  • ~> 2.7.9

DESCRIPTION

An issue was discovered in RubyGems 2.6 and later through 3.0.2. Since Gem::CommandManager#run calls alert_error without escaping, escape sequence injection is possible. (There are many ways to cause an error.)