RubySec

Providing security resources for the Ruby community

CVE-2020-36327 (bundler): Dependency Confusion in Bundler with Implicit Private Dependencies

ADVISORIES

GEM

bundler

SEVERITY

CVSS v3: 8.8 (High)

UNAFFECTED VERSIONS

  • < 1.16.0

PATCHED VERSIONS

  • >= 2.2.18
  • 2.2.10

DESCRIPTION

Bundler 1.16.0 through 2.2.9 and 2.2.11 through 2.2.17 sometimes chooses a dependency source based on the highest gem version number, which means that a rogue gem found at a public source may be chosen, even if the intended choice was a private gem that is a dependency of another private gem that is explicitly depended on by the application.