RubySec

Providing security resources for the Ruby community

CVE-2021-21305 (carrierwave): Code Injection vulnerability in CarrierWave::RMagick

ADVISORIES

GEM

carrierwave

SEVERITY

CVSS v3: 7.4

PATCHED VERSIONS

  • ~> 1.3.2
  • >= 2.1.1

DESCRIPTION

Impact

CarrierWave::RMagick has a Code Injection vulnerability. Its #manipulate! method inappropriately evals the content of mutation option(:read/:write), allowing attackers to craft a string that can be executed as a Ruby code. If an application developer supplies untrusted inputs to the option, it will lead to remote code execution(RCE).

(But supplying untrusted input to the option itself is dangerous even in absence of this vulnerability, since is prone to DoS vulnerability - attackers can try to consume massive amounts of memory by resizing to a very large dimension)

Proof of Concept

class MyUploader < CarrierWave::Uploader::Base
  include CarrierWave::RMagick
end

MyUploader.new.manipulate!({ read: { density: "1 }; p 'Hacked'; {" }}) # => shows "Hacked"

Patches

Upgrade to 2.1.1 or 1.3.2.

Workarounds

Stop supplying untrusted input to #manipulate!’s mutation option.