RubySec

Providing security resources for the Ruby community

CVE-2016-5697 (ruby-saml): XML signature wrapping attack

ADVISORIES

GEM

ruby-saml

SEVERITY

CVSS v3: 7.5

CVSS v2: 5.0

PATCHED VERSIONS

  • >= 1.3.0

DESCRIPTION

ruby-saml prior to version 1.3.0 is vulnerable to an XML signature wrapping attack in the specific scenario where there was a signature that referenced at the same time 2 elements (but past the scheme validator process since 1 of the element was inside the encrypted assertion).

ruby-saml users must update to 1.3.0, which implements 3 extra validations to mitigate this kind of attack.