RubySec

Providing security resources for the Ruby community

CVE-2021-39197 (better_errors): Older releases of better_errors open to Cross-Site Request Forgery attack

ADVISORIES

GEM

better_errors

SEVERITY

CVSS v3: 6.3 (Medium)

PATCHED VERSIONS

  • >= 2.8.0

DESCRIPTION

Impact

better_errors prior to 2.8.0 did not implement CSRF protection for its internal requests. It also did not enforce the correct “Content-Type” header for these requests, which allowed a cross-origin “simple request” to be made without CORS protection. These together left an application with better_errors enabled open to cross-origin attacks.

As a developer tool, better_errors documentation strongly recommends addition only to the development bundle group, so this vulnerability should only affect development environments. Please ensure that your project limits better_errors to the development group (or the non-Rails equivalent).

Patches

Starting with release 2.8.x, CSRF protection is enforced. It is recommended that you upgrade to the latest release, or minimally to “~> 2.8.3”.

Workarounds

There are no known workarounds to mitigate the risk of using older releases of better_errors.

References

For more information

If you have any questions or comments about this advisory, please